added “Privileged Contexts” and “Upgrade Insecure Requests